CAT tools: general technical issues

From ProZ.com Wiki

Jump to: navigation, search


Note: This article is a joint project of ProZ.com members and guests. All translators are invited to contribute freely. (Click "Edit" above; you must be logged in.)
If you don't know how wiki formatting works, see: http://en.wikipedia.org/wiki/Wikipedia:Cheatsheet



Contents

Overview

This article contains a record of the most common technical issues associated with the use of CAT tools. If you do not find here a solution to the issue you are encountering, use the CAT Tools Technical Help forum.


For issues related to the use of CAT tools not listed in this article, visit the corresponding pages:

CAT tools issues

LocStudio

Error message: ".NET Framework 2.0 or later must be installed first" when installing LocStudio on Vista

Open regedit, go to HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Net Framework Setup >NDP, rename "CDF" branch to "v5" (make sure the new name contains numbers), install Locstudio and rename the branch from p3. back.

Or else, try uninstalling Framework 4 and before installing LocStudio. Automatic updates will install Framework 4 afterwards.

Ref. http://www.proz.com/topic/214157

Passolo

How to integrate a colleague's translation bundle (with her strings/files translated) into my translation bundle

Project integration in Passolo depends on the project/bundle structure that you have. If the project manager is using 'Passolo Collaboration' to export the bundle and your colleage is using a copy of your bundle (Project > Bundle, Bundle), the three of you just need to click on 'File / Synchronize Exports' from time to time. However, if your colleague's bundle has been exported from your bundle (Project > Bundle > Bundle) you need to ask the person who did this export, because for exporting / importing you need the full version of Passolo.

CBG Transtool

How to view the number of untranslated words in (CBG) Transtool

CBG Transtool doe not have a built-in wordcount facility. However, you can try exporting original new segments, opening the export file in Word and checking the word-count there.

Ref. http://www.proz.com/topic/176504

Idiom

How to open several files at once with Idiom WorldServer Desktop Workbench 9.0.1.49 on Windows7 Professional

To open several files at once osing Idiom, try using MemoQ (translator /professional version) to import and export XLZ files directly. You can search in the complete MemoQ project (all files). This opens files in a separate tab.

Or else, export the segments of the old TM and convert it to a format that you can consult. For example, if you export "segments", it creates a plaintext file containing only the segments currently filtered-in, and you can convert that to an MS Word table or Excel sheet. Or, you can export to XLZ, unzip it and open the XLF file in it using an XLF viewer.

Ref. http://www.proz.com/topic/209848

Error message: "1603: Error installing Microsoft (R) .NET Framework" when installing Idiom Workbench

Right-click on the Idiom .exe file and select "Troubleshoot compatibility". Then, hit "Start Program" to make sure it fixes the issue.

Ref. http://www.proz.com/topic/152867 & http://www.proz.com/topic/152504

Desktop Workbench auto-search window missing / disappeared

If the auto-search window in Idiom Worldserver Desktop Workbench is not visible, right-click on the task bar and chose the option "Properties", in the "Task Bar" tab, chose the option "Superior/Top" for "Location of Task Bar on the Screen". This should restore the visibility of the auto-search window.

Ref. http://www.proz.com/topic/156433

Google translate

How to extract source text and paste target

To translate a text received via GTT outside the tool and deliver it via the tool, copy the source code of the target text using Opera to an offline HTML. Or else, choose to display the source text in non-translated segments by selecting "Settings" (right top corner of the window) > "Editing" and changing the display option. The change will not apply to already uploaded files, so you will have to upload them again.

Miscellaneous

Converting XLIFF or TTX into two separate files

To convert XLIFF or TTX files into two different files, you can try the following:

Import the file to Xbench and use "Export Items" to export them to either TMX or tab delimited text. The resulting text file can be opened in Excel and, from there you can copy and paste both columns to the respective source and target files.

Another option is to use Swordfish to export source and target from an XLIFF document to separate text files. Use these options from File menu: 1) Export Sources as Plain Text and 2) Export Targets as Plain Text.

Or else, use Rainbow (open-source): drop your TTX or XLIFF document(s) in "Input List 1", select "Utilities > Conversion Utilities > File Format Conversion", then "Parallel Corpus Files" for the output format, enter the output path as needed (if you have several input files you can output the source/target of all of them in a single file, or have a pair of output file for each input file) and click on "Execute".

Ref. http://www.proz.com/topic/215215

Source text is automatically inserted into target fields

Check the TM you are using. If source segments are inserted into target fields automatically (and specially if you receive no matches while working on the text or you get an "Analysis was interrupted" error message when trying to analyze the text), it is possible that you are working with the wrong TM.

Ref. http://www.proz.com/topic/215068

How to merge two .mdb TMs

You can merge two .mdb files using the "Maintain" function of SDLX. Launch the application, open the main TM and import the second TM into the first one. Make sure you chose the right option between "Overwrite existing" or "Add as new" in order to keep the entries you need in place.

Ref. http://www.proz.com/topic/213425

How to convert MDB into TMX

To convert an MDB file into TMX, use the "Maintain" function from SDLX to export the TM from the native (SDLX's) format to TMX.

Ref. http://www.proz.com/topic/199255

Which CAT tool should be used for the translation of .sql (HTML) files?

MetaTexis allows you to define a user-defined document type, permitting the identification of specific areas to be translated (e.g. test between quotation marks).

How to remove a third language from .TMX files

You can remove a third language from .TMX files using Olifant by loading the file to the application and deleting the unwanted language in the file's properties.

Or else, use Liquid XML Editor to make the necessary alterations in the preferences tab or a CAT tool such as Trados or Wordfast to create a new TM, import the TMX as is, and then export it again.

Ref. http://www.proz.com/topic/209507

How to translate Lectora RTF files

Since Lectora RTF files cannot be translated with any CAT tool, they first need to be converted into XTM to be translated with XTM Cloud.

Ref. http://www.proz.com/topic/206998

How to get the cleanest results for files converted with Nitro PDF Professional

To get the cleanest results for files converted with Nitro PDF Professional, execute the following operations: PDFTidy -> CZL -> PDFFix.

Ref. http://www.proz.com/topic/207536

Translating .RTF file in columns

To translate an .RTF file in columns, and if there are no translations in the target column, copy source segments to target. Then copy the target column into a new Word file, translate and clean. Finally copy it to the original file. If there are translations in the target column, same method may work. Or else, ask for a Trados .RTF External View (for translation with WF) or Xliff External View document (for Omega) from your client. WF does not support .xliff files with pre-translated segments.

Ref. http://www.proz.com/topic/203633

How to convert .TMX files into Gettext PO

To convert .TMX files into Gettext PO, try using Okapi Rainbow toolbox. Load the .TMX file into it and use the 'Translation Kit Creation' function to convert it into a PO package. Also, you can try with MemoQ's built-in terminology extraction module.

How to convert HTML special characters in .TMX files to plain text

To convert HTML special characters in .TMX files to plain text, ytu using Okapi Rainbow. This software allows you to process TMX files, searching and replacing regular expressions.

Ref. http://www.proz.com/topic/202243

How to fix a non-compliant .TMX file (with control characters that are invalid in XML document)

Some .TMX files may come with control characters that are invalid in XML document (often found in RTF-generated style sheet section). When one or more characters is in the TMX file, an error "hexadecimal value 0xHH is an invalid character" occurs when opening or importing the TMX file.

To open such TMX file in Olifant:

  1. Select the Import command from the File menu.
  2. Select the path of the TMX file to import.
  3. Click Open.
  4. An TMX Import Options dialog box opens.
  5. Make sure the option Check for invalid characters is set.
  6. Click OK.

A temporary copy of the file is created, where each invalid XML character will be replaced by _#xHHHH_ where HHHH is the Unicode hexadecimal value of the character. Then the temporary file is open. Note that these characters are left like this after: Olifant does not convert them back automatically when saving the file. You have to decide yourselves what you want to do with them.

You should use this option only when needed, as it increases the time it takes to open the file.

Ref. http://www.proz.com/topic/200111

How to export source and target segments into separate files

To export source and target segments into separate files, export TM into a tab-delimited TXT file, open in Excel and delete unnecessary column.

Ref. http://www.proz.com/topic/200041

How to copy and paste 'hidden' text into third party applications

To copy and paste hidden text, try with ABBYY Screenshot Reader to select the area on your PC screen that you want to copy and automatically use OCR to copy the text to your clipboard.

Also, try saving the file under a different name, selecting all text and changing its properties to make all text visible or selecting the hidden text, temporarily disabling the hidden attribute ('Format' > 'Font' > uncheck 'Hidden'). Then copy and then restore the Hidden attribute. Recording a macro for this can speed up the process.

Ref. http://www.proz.com/topic/199009

How to check for word repetition in TUs of TM

To do a QA on a TMX (or other TM format) to check whether any segments have duplicated words in them, try Xbench.

Ref. http://www.proz.com/topic/198901

Discussion related to this article

Please note that ProZ.com forum rules apply to this area.

Personal tools