Studio 2017 won't update confirmed segments in TM
Thread poster: Kerstin Kiss

Kerstin Kiss
Local time: 22:42
English to German
Nov 7, 2018

Hi there,

When I confirm a segment and change it later in the editor while proofreading to fix a mistake, the next fuzzy to this original segment in this document won't include the amendments I made. I tried it with all TM update options possible (overwrite, create new entry etc.), still does the same. That's really annoying and counterproductive as my texts are usually full of fuzzys and Studio keeps suggesting me only fuzzy matches with the mistakes. It seems to store only the ver
... See more
Hi there,

When I confirm a segment and change it later in the editor while proofreading to fix a mistake, the next fuzzy to this original segment in this document won't include the amendments I made. I tried it with all TM update options possible (overwrite, create new entry etc.), still does the same. That's really annoying and counterproductive as my texts are usually full of fuzzys and Studio keeps suggesting me only fuzzy matches with the mistakes. It seems to store only the version of the segment I confirmed at first. Did not have this problem with earlier versions of Studio. The updating checkboxes of all TM's used are activated.

A friend of mine has the same problem. Any ideas?

Thank you!
Collapse


Ulrich Schramm
 

Sandra& Kenneth  Identity Verified
Israel
Local time: 23:42
Member (2009)
French to English
+ ...
I can't solve your problem, but you can try opening the target lg. XLIFF and working in it directly Nov 9, 2018

Very recently, I had a problem updating the TM in Studio 2019. After trying to update the TM field in a new project (which failed), the program stopped recording or updating the confirmed segments in the TM altogether (got the unhelpful message: Failed to update the translation unit. An unspecified error occurred).

What I did is I opened the XLIFF file in the target language by double-clicking on it (without any project creation procedure) and it automatically created a new project
... See more
Very recently, I had a problem updating the TM in Studio 2019. After trying to update the TM field in a new project (which failed), the program stopped recording or updating the confirmed segments in the TM altogether (got the unhelpful message: Failed to update the translation unit. An unspecified error occurred).

What I did is I opened the XLIFF file in the target language by double-clicking on it (without any project creation procedure) and it automatically created a new project at the same location. Now re-confirm the segments in the XLIFF, one by one.
Problem solved.
HTH,
Sandra

[Edited at 2018-11-09 07:56 GMT]
Collapse


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 00:42
English to Russian
Try Nov 9, 2018

File > Options > Auto-propagation > Check the upper 3 boxes with 100 for 'Minimum match value'.

Also remember: if you use the Perfect Match feature (if you do, you definitely know that you do), PM segments won't change by Auto-propagation even when unlocked.
If you don't know what is Perfect Match, then this disclaimer is not relevant for you.

*I assume that when you proofread, all your segments are already populated. If so, the problem may be not with TM but with
... See more
File > Options > Auto-propagation > Check the upper 3 boxes with 100 for 'Minimum match value'.

Also remember: if you use the Perfect Match feature (if you do, you definitely know that you do), PM segments won't change by Auto-propagation even when unlocked.
If you don't know what is Perfect Match, then this disclaimer is not relevant for you.

*I assume that when you proofread, all your segments are already populated. If so, the problem may be not with TM but with the above settings.

[Edited at 2018-11-09 09:53 GMT]
Collapse


 

Paco Blanco
China
Local time: 05:42
English to Spanish
+ ...
Just disable "LookAhead" Nov 29, 2018

I came across this question after experiencing a similar issue and found a solution elsewhere, so I thought to share it here. The solution that worked is in this link:

https://community.sdl.com/product-groups/translationproductivity/f/90/t/19940

In short, just go to Options->Editor->Automation-> and under "Translation Memory", disable
... See more
I came across this question after experiencing a similar issue and found a solution elsewhere, so I thought to share it here. The solution that worked is in this link:

https://community.sdl.com/product-groups/translationproductivity/f/90/t/19940

In short, just go to Options->Editor->Automation-> and under "Translation Memory", disable the "Enable LookAhead" checkbox.
(This is for Trados 2019, it may differ slightly for 2017).

After checking the Documentation Center, (you can search "Faster translation results with LookAhead"), I learnt that this feature is intended to provide faster TM matches by performing a background lookup for the next few segments that are below the current one, so when you jump to the next segment (or a few segments ahead) and there is a fuzzy match, what you get is actually a cached match and not a fresh lookup. The problem here, as it seems, is that these "cached images" are not updated whenever you modify the original segment.

I think SDL should look into this, because I can see a very recurring use scenario where this may be rather an issue:
-Translator finishes translating a segment and jumps to the next one after confirming.
-One or a few segments later: "No wait, I think that sentence was better translated as..." / "Oh, silly me, I made a mistake there...", etc. (Translator modifies the confirmed segment)
-Translator keeps on, and the next (or 2nd next, or 3rd next) segment is a fuzzy match of that segment modified earlier: "Oh, joy! A high fuzzy, yeah, less typing work... But wait, why this shows just the older version? Ok, whatever..." (Translator makes the required adjustments)
-This issue appears later again, and again, and again...
-Frustration ensues.

The End.
Collapse


Ulrich Schramm
 

Ivana Bojcic  Identity Verified
Croatia
Member (2011)
German to Croatian
+ ...
Same problem Nov 29, 2018

... also, I disabled the look-ahead option and everything is the same. No automatic propagation although it has all been ticked and checked under Automation.

I paid great money for this software, anybody from Trados feeling at least a bit of shame?


Heloísa Helena Benetton Costa
 

Angela Rimmer  Identity Verified
United Kingdom
Local time: 21:42
Member (2014)
German to English
+ ...
TM update tip Nov 29, 2018

There is an odd bug that I come across with certain TMs in Trados, where you think you are updating the TM and it turns out you aren't. I have found that with some TMs, if they have descriptor fields and these fields are empty, they do not update. They won't even update if you do a batch task.

- First, check that the TM is updating. I usually just translate a segment, confirm it, and then put my cursor back in that segment and look to see if the TM recognises it as a 100% match now.
... See more
There is an odd bug that I come across with certain TMs in Trados, where you think you are updating the TM and it turns out you aren't. I have found that with some TMs, if they have descriptor fields and these fields are empty, they do not update. They won't even update if you do a batch task.

- First, check that the TM is updating. I usually just translate a segment, confirm it, and then put my cursor back in that segment and look to see if the TM recognises it as a 100% match now. If not, then it did not update.

- If the TM is not updating, check whether there are any descriptor fields associated with the TM. To do this, open the project settings, navigate to "Translation Memory and Automated Translation > Update" and look to see if there are any fields in the list there. If there are fields, make sure each field has an entry.

- Click OK to apply the changes. Your TM SHOULD update now.

For example, one TM where this problem always occurs for me has the field "Project". I just go to that field, enter the project number and then voila! The TM starts updating like normal again.

It is a weird bug that I have discussed with Trados but that hasn't yet been fixed yet. I'm not sure whether this is your issue as well, but worth checking anyway.
Collapse


 

Kerstin Kiss
Local time: 22:42
English to German
TOPIC STARTER
still the same ... Nov 29, 2018

Thank you for all your proposals and your efforts. Unfortunately, nothing has really worked out so far.

Some of my colleagues have the same problem. I do not exactly know what feature Trados implemented that causes such problems. In fact, Trados is supposed to eliminate such problems with inconsistency and not causing them.

Currently, when I do change a segment, I delete the old entry in the TM (not even editing in the TM itself helps) before I confirm the new, amended
... See more
Thank you for all your proposals and your efforts. Unfortunately, nothing has really worked out so far.

Some of my colleagues have the same problem. I do not exactly know what feature Trados implemented that causes such problems. In fact, Trados is supposed to eliminate such problems with inconsistency and not causing them.

Currently, when I do change a segment, I delete the old entry in the TM (not even editing in the TM itself helps) before I confirm the new, amended one. That's cumbersome but it works best. As long as I only update one TM. If the old, wrong segment has been saved in another TM, Studio keeps suggesting the old one, no matter how I rank the TMs, it does not even suggest the new one then. Very awkward. Really makes me considering changing the software.
Collapse


 

Heloísa Helena Benetton Costa  Identity Verified
Brazil
Local time: 19:42
Member (2005)
English to Portuguese
+ ...
Studio 2017 still not updating confirmed segments in TM Oct 10

Hey people.

Same problem with a TM here. Tried all the above suggestions and nothing. Very difficult project from a very important client and I can't even search what I did myself to keep consistency.

This is very serious for a program like Studio. I am deeply concerned... and mad!


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2017 won't update confirmed segments in TM

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search