Pages in topic:   < [1 2]
How to install plugin Okapi in OmegaT
Thread poster: Meyers (X)

Didier Briel  Identity Verified
France
Local time: 13:49
English to French
+ ...
Not enough elements Oct 4, 2018

Magda Phili wrote:
Thanks for your help. I was able to convert the memory into .tmx and translated a xliff test file which was then sent to a colleague to check compatibility with Trados. There was an error however in opening the file. Trados couldn't recognise the target language. I double checked the project on OmegaT and it was correct.

Are you sure the target language in the OmegaT project was exactly the same as in the XLIFF file?

What could be the problem here?

If you are sure of the above, no idea.

I need to make sure that clients will read the files.

I suggest subscribing to the Yahoo support group. This forum is not the best place to try and detect what went wrong:
https://groups.yahoo.com/neo/groups/OmegaT/info

Also, when translating xliff files on OmegaT are tags to be removed or not? I tried both with and without them and we still can't read the translated texts in Trados.

You should not remove the tags. You should also usually not allow segmentation.

Didier


 

M.Phili  Identity Verified
Italy
Local time: 13:49
Member (2013)
Italian to Greek
+ ...
Thank you, it works! Oct 17, 2018

Hi Didier,
After a couple of tests, I confirm it works.
It's important to have the latest OmegaT version with JRE.
Thanks for all your help.
Much appreciated.
I wouldn't want to abandon my fave CAT tool and have now discovered its new features that makes it even more efficient, practical and - above all - compatible!


 

Frances Pope
Canada
French to English
Okapi XLIFF option not shown in list Jan 29

M.Phili wrote:

Thank you so much Didier!
I've downloaded OmegaT 4 and after a few trials and errors I was able to open the xliff files. What a relief that was! At first OmegaT didn't read the files but then I unchecked one of the options about segmenting (I found this article very useful for this: http://www.velior.ru/2015/12/27/translating-studio-files-in-omegat-never-been-easier/) and I also unchecked a second Okapi filter (2 files). That's the only way I was able to make it work.
If only I had known earlier... I've "lost" quite a lot of work because of this. Anyway, better late than never.
Again, thank you.
Magda

[Edited at 2018-09-20 11:08 GMT]


Hi M.Phili,

I am having a similar problem to the one you described, and wondered if you had any pointers for how you fixed it?

- I had OmegaT 3.6 with Okapi installed, which showed up in the File Filters options, but still could not open XLIFF files.
- Having read previous posts on this forum I installed OmegaT 4 (without deleting the previous version), along with Java 8.
- Okapi is still present in my OmegaT Plugins folder, but when I open OmegaT 4, Okapi is not shown in the File Filters list which would allow me to select it.
- Therefore, no XLIFF files show up in my Source documents when I open the Source folder in OmegaT; however I have placed the XLIFF files in the Source folder and can see that they are there by opening My Documents > OmegaT > Source.
- I have relaunched OmegaT (and restarted my computer just in case) but still no luck.
- I have unchecked the box for "Enable Sentence-Level Segmenting" too.

Maybe I should have deleted the older version OmegaT 3.6 and my previous download of Okapi before trying to use Okapi in OmegaT 4?


 

Didier Briel  Identity Verified
France
Local time: 13:49
English to French
+ ...
Various answers Jan 30

Frances Pope wrote:

- I had OmegaT 3.6 with Okapi installed, which showed up in the File Filters options, but still could not open XLIFF files.

Probably because you didn't uncheck the native OmegaT XLIFF filter.

- Having read previous posts on this forum I installed OmegaT 4 (without deleting the previous version), along with Java 8.
- Okapi is still present in my OmegaT Plugins folder, but when I open OmegaT 4, Okapi is not shown in the File Filters list which would allow me to select it.

You have probably installed the Okapi plugin for OmegaT 3.6, but not for OmegaT 4 (in its own /plugin folder).

Maybe I should have deleted the older version OmegaT 3.6 and my previous download of Okapi before trying to use Okapi in OmegaT 4?

You should probably check the /plugin folder of your OmegaT 4 installation.

Didier


 

Frances Pope
Canada
French to English
Some XLIFF files open, others don't Jan 31

Thanks a lot for your reply, Didier.

[quote]Didier Briel wrote:

You have probably installed the Okapi plugin for OmegaT 3.6, but not for OmegaT 4 (in its own /plugin folder).

-- This could have been the problem - I have now made sure that Okapi is in the correct Plugins folder.

I have been able to open some SXLIFF files, but not others, and I can't figure out what the difference is between them. The files which I have been able to open have the following extensions:
- .docx
- .docx.sxliff
- .xliff

Under the File Type header in the documents folder, all of the above documents are listed as SDLXLIFF.

Yet, having tried to open other files with the same file extensions as those above, I have been unable to open the files - although copied into my project's Source folder, the files do not show up, as if they were an unsupported file type.

Is there another variable applying to these files that could make them incompatible or could explain why OmegaT won't open them?


 

Didier Briel  Identity Verified
France
Local time: 13:49
English to French
+ ...
Various answers Feb 1

Frances Pope wrote:
I have been able to open some SXLIFF files, but not others, and I can't figure out what the difference is between them. The files which I have been able to open have the following extensions:
- .docx

That's not an XLIFF file, that's a Word document.

- .docx.sxliff

I suppose you mean .sdlxliff.

- .xliff

Under the File Type header in the documents folder, all of the above documents are listed as SDLXLIFF.

Yet, having tried to open other files with the same file extensions as those above, I have been unable to open the files - although copied into my project's Source folder, the files do not show up, as if they were an unsupported file type.

Is there another variable applying to these files that could make them incompatible or could explain why OmegaT won't open them?

There could be some incompatible files, but these are rather rare.
If you are sure:
- You have unchecked OmegaT native XLIFF filter;
- You have checked the SDLXLIFF Okapi filter,
I suggest you ask for help in the OmegaT user support group,
https://groups.yahoo.com/neo/groups/OmegaT/info
where people both from OmegaT and Okapi can help you troubleshoot the issue.

Didier


 
Pages in topic:   < [1 2]


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


How to install plugin Okapi in OmegaT

Advanced search






SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search